Skip to main content
Cartegraph Campus

Cartegraph System Requirements: Spring 2021

The requirements for the following solutions are listed below:

Cartegraph OMS

The following are the requirements for the installation and use of hosted and on-premise deployments.

Customer Workstation

Operating System:
  • Windows 10
  • All Microsoft updates must be installed.
  • 64-bit only
Processor and Memory (RAM): Must meet or exceed the requirements of the operating system.
Available Hard Disk: 500 MB recommended
Supported Web Browsers:
  • Edge (latest version)
  • Chrome (latest version)
Connectivity:
  • Always connected
  • External Internet Access is required
Monitor: Minimum screen resolution 1280 x 768

Map Support

  • Esri ArcGIS Online
  • Supports latitude/longitude coordinates only
  • Web map support for the Cartegraph One app

GIS Integration

  • Esri ArcGIS Online
  • On-Premise GIS
    • Esri ArcGIS Server for Windows
    • Esri ArcGIS Portal for Windows (federated with ArcGIS Server)
    • Requirements:
      • Version 10.4.1 to 10.8.1
  • ArcGIS Pro 2.4 to 2.6
  • TLS 1.2
  • SHA256+ SSL certifications
  • Web Adaptor for hosted deployments (applies to ArcGIS Server and Portal only)
  • Standard or Advanced version (applies to ArcGIS Server and Portal only)
  • Only unsecured or GIS-tier authentication (applies to ArcGIS Server and Portal only)
  • Cartegraph add-in for ArcMap or ArcGIS Pro (recommended)
  • Cartegraph SOE for ArcGIS Server (recommended)

For On-Premise Deployments

If your organization chooses to use an on-premise deployment the following items are required in addition to those listed above. Please make note of differences for two-tier and three-tier configurations. A Web servicer, Application server, Database, and Project Home are not required for hosted deployments.

Web Server

Operating System:
  • Windows Server 2012, 2012 R2, 2016, or 2019 (recommended)
  • .NET version 4.8
  • All Microsoft updates must be installed.
Processor and Memory:
  • Multi-core processor 2.0 GHz or faster
  • 8 GB RAM
  • 100/1000 Ethernet connection
IIS:
  • Version 8, 8.5, 10
  • SSL SHA-256 is required
  • The server requires Transport Layer Security (TLS) protocol version 1.2 enabled
Other:
  • Internet Access
  • Outgoing SSL communication required.
  • If a two-tier environment:
    • User ID with read and write access to the Project Home
    • User ID and DB ownership for the database
    • SMTP Compliant Email Server
    • Permissions to run the Windows Task Scheduler
  • If a three-tier deployment, the operating system must be the same on both the Web and Application servers.
  • Outbound port 10943 opens to octopus.cartegraph.com.

Application Server

In a two-tier environment, this does not apply because the Web Server does the Application Server's job.

Operating System:
  • Windows Server 2012, 2012 R2, 2016, or 2019 (recommended)
  • .NET version 4.8
  • All Microsoft updates must be installed.
Processor and Memory:
  • Multi-core processor 2.0 GHz or faster
  • 8 GB RAM
  • 100/1000 Ethernet connection
IIS:
  • Version 8, 8.5, or 10
  • SSL SHA-256 or later is required
  • The server requires Transport Layer Security (TLS) protocol version 1.2 enabled
Other Environment Requirements:
  • Internet Access
  • Outgoing SSL communication required
  • User ID with read and write access to the Project Home
  • User ID and DB ownership for the database
  • SMTP Compliant Email Server
  • Cartegraph recommends adding this server’s URL to the Safe list on the firewall between the DMZ and the internal network to eliminate flooding issues.
  • Outbound port 10943 open to octopus.cartegraph.com.
  • If a three-tier deployment, the operating system must be the same on both the Web and Application servers.

The server supports Transport Layer Security (TLS) protocol version 1.2 enabled.

Database

Supported Database Types:

SQL Server 2012, 2014, 2016, 2017, or 2019 (recommended)

SQL Express is not supported.

Available Hard Disk: 5 GB or more free disk space
Shared Components: Full-text and semantic extractions for the search feature installed.
TLS The server supports Transport Layer Security (TLS) protocol version 1.2 enabled.

One exception is that ODBC Import will fail if the import source database is on a TLS 1.2-only enabled database server. In other words, if the import source database is on a Database server with at least TLS 1.0/1.1 enabled, ODBC import will work.

Project Home

Shared folder hierarchy to store attachments, import/export format files, and reports.

Available Hard Disk: 5 GB or more free disk space
Other Considerations:
  • Can be placed on a network share or directly on the Application server for three-tier deployments or the Web server for two-tier deployments.

  • Can grow significantly based on the number of attachments being uploaded

  • If being placed on the Application server for three-tier deployments or the Web server for two-tier deployments, consider a separate drive for growth.

Cartegraph FMS

The following are the requirements for the installation and use of hosted and on-premise deployments. These requirements apply to the X, Property Portfolio, and X solutions

User Devices

Users can interact with FMS using a variety of internet-connected devices, includes desktops, tablets, and smartphones using the latest version of one of the following modern browsers:

  • Chrome
  • Edge
  • Firefox
  • Safari

Web Server

The Web Server provides secure access to FMS content and resources.

Operating System: Windows Server 2016 or  Windows Server 2019
Processor and Memory:
  • Multi-core processor (4 CPUs)
  • 4 GB of RAM per CPU
Available Hard Disk:

Two 50 GB or more disk drives

FMS Data

This is where FMS Foundation stores configuration backups as well as data for use in applications (e.g: view bys, KPIs, etc.)

  • The default location is C:\InVisionData. This location can be changed, but the new location must be a directory on the same server as FMS Foundation. This directory will be created by the installer if it does not exist.

FMS Documents

This is where FMS Foundation stores images for use in applications.

  • If the FMS Documentation path is a UNC path, then the InVision Foundation App Pool identity must be a domain account with read/write access to the UNC path.

These directories are NOT backed up as part of the FMS Backup and Restore Utility – therefore the system administrator should establish an appropriate file system backup mechanism for these storage locations.

Other Environment Requirements:
  • Esri ArcGIS Web Adaptor. (same version as ArcGIS Enterprise)
  • SQL Server Native client
  • IIS enabled
  • Https enabled
  • Python 2.7 (32-bit)
  • Notepad ++
  • SSL certificate Note: certification must come from a trusted certificate authority.
  • DNS entries to identify server as the desired URL and machine FQDN
  • IIS application pool service account that is a member of the local Administrators security group with a password set not to expire

Application Server (GIS)

The Application Server – or GIS Server – provides access to geographic information system using Esri’s ArcGIS Enterprise.

Operating System: Windows Server 2016 or  Windows Server 2019
Processor and Memory:
Available Hard Disk: Two 50 GB or more disk drives
Other Environment Requirements:
  • ArcGIS Enterprise 10.8.1 or 10.7.1 (either Portal with federated ArcGIS Server or Standalone ArcGIS Server)
  • ArcGIS for Server service account with administrator privileges
  • SQL Server Native client
  • SSL certificate Note: certification must come from a trusted certificate authority.

Database Server

The Database Server stores relevant FMS facility datasets.

Supported Databases:
  • SQL Server 2017 or 2019 (recommended)
  • SQL Server Management Studio 

 SQL Server Management Studio can be installed on this server or on one of the other servers listed.

Processor:
  • Dual-core processor 4 CPUs
  • 4 GB of RAM per CPU
Available Hard Disk: Two 50 GB or more disk drives
Other Environment Requirements: Either SA acct (if MS SQL Server) or acct with permissions to create databases on DB server as DBO. This account will need to be mapped to the DBO schema for the databases created for FMS.

Desktop Workstation

The Desktop workstation has software installed to manage and configure ArcGIS and SQL Server.

  • ArcGIS Desktop (same version as ArcGIS Enterprise)
  • ArcGIS Desktop Interoperability Extension
  • SQL Server Management Studio

General Requirements

  • Your Customer ID: A unique ID from your Cartegraph account record available from your Project Manager. The ID looks similar to A-607-00000.
  • VPN accounts (2) with access to the web, application, and database servers.
  • Accounts with administrative privileges on the web, application, and database servers.

Cartegraph One

This app can be used on both smartphones and tablets. The requirements listed are for the current version. Cartegraph One is released independently, to app stores, regardless of what Cartegraph OMS version, and the requirements can change independently from Cartegraph OMS releases.

Cartegraph One requires that Cartegraph OMS must be on the latest version of Spring 2019 or later.

Android

  • Google Android OS version: 7.0 to 11.0
  • RAM: 2 GB is the minimum and 4 GB are recommended
  • GPS enabled device is recommended
  • The device time zone should match the OMS instance you are connected to
  • Your device must be at least 320px wide on its shortest side to support Portrait Mode
  • Your device must be at least 640px wide and 640px tall to support Landscape Mode
  • Processors: Qualcomm Snapdragon:
    • Model 430 line or higher
    • Model 650 line or higher
    • Model 710 or higher
    • Model 820 or higher
      • Samsung Exynos7 Quad 7570 or higher

Devices

  • Android 7.0+-9.x requires the latest version of the Google Chrome app found in the Google Play Store
  • Android 10.0+ requires the latest version of the Android System WebView app found in the Google Play Store.
  • Recommended Android Tablet: Galaxy Tab 4+ 10.5 Cellular or a tablet that can receive Android 9 Pie+.
  • Amazon tablets or Android devices without Google Play are not supported.

Apple

  • iOS 13+ or iPadOS 13+
  • RAM: 2 GB is the minimum and 4 GB are recommended
  • Setup with internet connectivity
  • Active iTunes account for the first download and updates
  • GPS enabled device is recommended
  • The device time zone should match the OMS instance you are connected to
  • Your device must be at least 320px wide on its shortest side to support Portrait Mode
  • Your device must be at least 640px wide and 640px tall to support Landscape Mode

    Devices

    Cartegraph recommends using the most current devices, and for tablets iPad Pro.

    • Mini fourth generation, model numbers A1538 and A1550
    • Mini fifth generation, model numbers A2133, A2124, and A2126
    • iPad fifth generation, model numbers A1822 and A1823
    • iPad sixth generation, model numbers A1893 and A1954
    • iPad seventh generation, model numbers A2197, A2198, and A2200
    • Air, third generation, model numbers A2152, A2123, A2153, and A2154
    • Air 2, model numbers A1566 and A1567
    • Air 3, model numbers A2123, A2152, A2153, and A2154
    • Pro first generation, model numbers A1584, A1652, A1673, A1674, and A1675
    • Pro second generation, model numbers A1670, A1671, A1821, A1701, A1709, and A1852
    • Pro third generation, model numbers A1980, A2013, A1934, A1979, A1876, and A1983
    • Pro fourth generation, model numbers A2069, A2229, and A2233

    External GPS Receiver

    These are the devices Cartegraph supports:

    • Leica: Zeno GG04 plus with processor board firmware version 1.0.20 or later
    • Eos: Arrow Lite, Arrow 100, Arrow 200, Arrow Gold with firmware version 2.02251 or later.

    Both Leica and Eos provide an app to configure all the settings related to the high precision receiver. The Leica or Eos app needs to be installed on the same device where Cartegraph One is installed.

    Cartegraph for iPad

    This app can only be used on an iPad in portrait mode. The requirements listed are for the current version. Cartegraph for iPad is released independently, to app stores, regardless of what Cartegraph OMS version and the requirements can change independently from Cartegraph OMS releases.

    • iOS 13+ or iPadOS 14+
    • Setup with internet connectivity
    • Active iTunes account for the first download and updates
    • GPS enabled device is recommended

    See above for the supported devices.